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TThhee  NNeettVViieewwMMaasstteerr  UUttiilliittyy  
 
The NetViewMaster Utility is a software tool for network administrators that allows the 
configuration and control of Compuprint Serial Matrix Printers remotely connected to the 
Ethernet LAN. 
 
With this tool the installed printers may be controlled, configured and organized easily.  
 
The main features are: 
 
• Device Discovery: searches for the devices within a range of IP addresses. 
• Printer Organization: the printers connected to the network can be organized into logical 

groups in a hierarchically structured tree. 
• Printer Status Report: checks the printer’s status and reports alarms. 
• Printer Configuration: the remotely connected printers may be configured as needed from 

the administrator’s workstation. 
• Firmware Updating: provides a firmware downloading function to upgrade both the base 

and the LAN card firmware. 
• Remote Operator Panel Management: provides a virtual operator panel for the remotely 

connected printer at the administrator’s workstation that allows to perform all functions 
normally achieved pressing the operator panel keys. 

 
The NetViewMaster Utility also provides the basic status management for third-party printers 
compliant to the standard MIB objects. 

OOppeerraattiinngg  SSyysstteemm  CCoommppaattiibbiilliittyy  
The NetVieMasteris a Java based application and can be run on any platform supporting the 
Java Run Time Environment version 6 or newer. 
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IInnssttaalllliinngg  tthhee  NNeettVViieewwMMaasstteerr  UUttiilliittyy  

IInn  WWiinnddoowwss  EEnnvviirroonnmmeenntt  
The NetViewMaster Utility needs Java Virtual Machine (JVM) fully 6 compliant, which can be 
downloaded from http://java.sun.com web site. 

 
1. After installed JRE, run the SETUP.exe file (be sure to have Administrator rights) and 

follow the instructions. 
2. Extract  file to the c:\NETVIEWMASTER directory. 
3. Run NETVIEWMASTER (executable Jar file) from the shortcut of desktop.  

The NetViewMaster Utility displays the Login  window: 
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4. Default User is “admin”; Default Password is “admin”; 
 
 
and after the login and password entry the main window appears: 
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HHooww  ttoo  cchhaannggee  PPaasssswwoorrdd  

To change Password push the button “Change User or Password into the Login Dialog. 
It will show the below window: 
 

 
 
Insert  new User or New password and Old Pwd in the  appropriate textbox and at last click on 
the button “Modify”. 
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TThhee  NNeettVViieewwMMaasstteerr  UUttiilliittyy  MMaaiinn  WWiinnddooww  
  
The NetViewMaster Utility Main Window, shown in the following figure, is divided mainly into 
three parts: the Menu Bar and the Tool Bar provide the printer database management tools, 
whereas the Printer Database window displays the database information. 

 
The Menu Bar contains the four menus (File, Edit, Status,Scan,Printer operation and Help) 
used to control the functions of the program.  
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The Tool Bar contains the icons of the shortcuts for the most commonly used menu functions.  
 
The Printer Database window shows an organized list of printers, configuration files, and 
firmware download files. 
 
The following is a brief description of these screen areas. 
 

TThhee  MMeennuu  BBaarr  
The NetViewMaster Utility menu bar is located at the top of the main window and provides the 
following items: 

 
• File Menu 
• Edit Menu 
• Status Menu 
• Scan Menu 
• Printer Configuration Menu 
• Help Menu 
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TThhee  FFiillee  MMeennuu  
The File pull-down menu offers the main file management functions for the printer 
databases. 
 

 
 

New Database To create a new database file. 
Open Database To open an existing database. 
 

With the NetViewMaster Utility you can open only one database at a time. If a database is 
already open, you are asked to save changes to the current database before  

creating the new one. 

 
Save To File To save the current database file. The program prompts the user to enter 

a name for the file. 
Exit To end the NetViewMaster Utility program. 
 

 

TThhee  EEddiitt  MMeennuu  
This menu allows you to manage the printer database contents: folders, printer devices, 
configuration files, or firmware download files. 
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Insert To add a folder, a printer device, configuration file, or firmware download file in 

a previously selected folder. A corresponding icon is placed in the folder: 
 
The example aside shows the database 
“Network Scan” containing the folder “Scan 
Folder” with some printer icons: 
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The Insert item offers the following selections: 

 
 

Folder The program prompts for the name of the new folder to be added. 
Enter the folder name and click OK. 
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Printer The program displays a data entry dialog to record printer 

identification values and network parameters. 
The data entry dialog is divided into two different parameter 
groups: Identification and Net 

 

 
 

Name Enter an easily identifiable name for the printer. 
Model This is a read-only field. The printer model is 

inserted by the program as soon as it has 
discovered the printer identified by the IP address 
(in the Net parameter group). 

User Read only – name of printer’s User 
Password Read only – password(encrypted) of the user 
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IP Address Enter the printer’s IP Address in this field. 
Netmask Enter the Netmask that identifies the printer 

connection. 
Port rfu 
Timeout rfu 
Workgroup Enter the printer’s Workgroup in this field    * 

As soon as the new printer data are confirmed, the NetViewMaster Utility tries to contact the 
printer to update its current status. 

If the printer is not found within the time indicated as Timeout, the NetViewMaster Utility displays the 
printer in the database as “not ready”. 
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Configuration File Selecting the Configuration File item, the program shows 

the following prompt, where you can enter the name of the 
configuration file, or look for it on your computer by 
pressing the Browse button. 

 

 
Pressing OK allows the NetViewMaster Utility to insert the selected 
configuration file into the current folder. See also “Inserting a Configuration File 
into a Folder” and  “Configuring the Printers in the Database”, later in this 
manual. 
Firmware File Selecting the Firmware File item, the program shows the 

following prompt, where you can enter the name of the 
firmware file you want to download directly, or look for it on 
your computer by pressing the Browse button. 

 

 
Pressing OK allows the NetViewMaster Utility to insert the selected firmware file 
into the current folder. See also “Inserting a Firmware File into a Folder” and  
“Updating the Printer’s Firmware Version” later in this manual. 
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Cut Selecting this function removes the selected item (folder, printer or file) from the 

database and copies it into the paste buffer. 
Copy Selecting this function copies the selected item into the paste buffer. The 

selected item remains unchanged. 
Paste The item inserted in the paste buffer (with the Cut or Copy function) is put in 

the selected position in the database tree. 
Delete The selected item is removed permanently from the database. 
 

TThhee  SSttaattuuss  MMeennuu  
 

 
 
Check Now Selecting this function the NetViewMaster Utility performs 

a check on all printers connected to the network and 
updates all the printer status.  

Check List Printers W/E 
 

 

 
 
Selecting this function the NetViewMaster Utility performs 
a check on all printers connected to the network and will 
show only the printers that are “On-line” or “Warning” or in 
“Alarm” status as for the user selection. 
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Fig. 1: 
Check Periodically Flag for enabling or disabling the status polling. When the 

periodical check is selected the NetViewMaster Utility 
performs an automatic check every about 10 seconds. 

 
See also “Checking the Printer Status” later in this manual. 
 

TThhee  SSccaann  MMeennuu  
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Fig: 2 

  
Printers Net Scan(insert) The NetViewMaster Utility searches for the connected printers 

within a specified IP-address range by sending a burst of directed 
SNMP requests to each IP address within the range. 
The printer find in the range are inserted into the existing 
Database. 
 

Printers Net Scan(new) The NetViewMaster Utility searches for the connected printers 
within a specified IP-address range by sending a burst of directed 
SNMP requests to each IP address within the range. 
The current database is closed, and a new database is created 
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TThhee  PPrriinntteerr  OOppeerraattiioonnss  MMeennuu  

 

  
Printer 
Configuration 

Edit the configuration file of the selected item (printer) of the database 

Operator Panel Select the printer for which you want to see the virtual operator panel. 
Selecting this function the NetViewMaster Utility the corresponding 
operator panel appears on the screen. 

Capture Printer 
Infos 

Selecting this function the NetViewMaster Utility get the configuration 
from printer device and the configuration value are show.   

Reboot Printer Selecting this function the NetViewMaster Utility reboot  the selected 
printer on the database . 

TThhee  TTooooll  BBaarr  

 
The tool bar shows a series of icons that allow an easier access to the menu functions: 
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Open a new database 

 
Expand the information tree 

 
Create a new database 
  

Reduce the information tree 

 
Add a new folder 

 
Send a firmware file to the devices 

 
Save database 

 
Send a configuration file to the devices 

 
Add a new printer 

 
Edit a configuration file 

 
Add a new firmware file 

 
Remote Panel management 

 
Add a new configuration file  Get the configuration from a device 

 Cut an object 
 

Printer net scan (for update) 

 
Copy an object 

 
Printer net scan (new) 

 
Paste an object   

 
Edit an object’s field   

 Delete an object   
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SSeettttiinngg  uupp  tthhee  PPrriinntteerr  DDaattaabbaassee  
The Netviewmaster’s main features are the collection, organization, and management of the 
printer database. 
 
The database may be set up manually or with an automatic discovery feature, with which the 
program searches for the connected devices and automatically inserts them into the current 
database file. 
 

GGrraapphhiicc  CCoonnvveennttiioonnss  UUsseedd  iinn  tthhee  NNVVMM  
The graphics used in the NetViewMaster Utility windows have the following meanings: 
 

  This symbol appears beside the folders and printer symbols. When clicking on it, the 
object view toggles between the expanded ( ) and the collapsed ( ) view, that is the 
details for the object are shown or hidden. 

 
The printer in the database is ready and working normally. 

 
The printer in the database is ready and working, but a consumable is running out. The 
printer will probably need an operator’s intervention soon. 

 
The printer in the database is in alarm or standby - no more jobs will be printed. An 
operator’s intervention is necessary.  

 
The printer connection is lost. An operator intervention is necessary. The printer has 
been removed or the connection is interrupted. 
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C  
Configuration file. The configuration file may be inserted into a folder to indicate the 
current configuration of the printers in that folder. 

F  
Firmware file. The firmware file may be inserted into a folder to indicate the current 
firmware version of the printers in that folder. 

AAuuttoommaattiicc  DDeevviiccee  DDiissccoovveerryy  
This procedure is useful for setting up the printer database for the first time.  
 
The NetViewMaster Utility searches for the connected printers within a specified IP-address 
range by sending a burst of directed SNMP requests to each IP address within the range. 
 
During the device discovery procedure the NetViewMaster Utility maps Compuprint Serial 
Matrix Printers for complete management, getting the proprietary MIB objects supported. 
Third-parties vendors devices are mapped for basic status reporting only. 

  

HHooww  ttoo  SSttaarrtt  tthhee  AAuuttoommaattiicc  DDeevviiccee  DDiissccoovveerryy  

The first-time automatic device discovery is started pressing the  button on the 
NetViewmaster ’s tool bar. 
 
The following mask is displayed: 
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*    
The From and To IP-addresses define the start and stop addresses of the range in which the 
connected printers will be checked. Mask defines the Netmask for the search procedure. 
 
The value set for Time out defines the time the program waits for a reply from a device connected 
to each IP-address. If no printer is detected, after the time has passed, the program goes to the 
next IP address within the range. The time-out setting is useful when performing a device 
discovery procedure on large networks that normally take a long time. The time-out ranges 
between 300 milliseconds and 100 seconds. 
The value set for Workgroup in textarea defines the workgroup name of printers to be searched. 
The value set for “Search for Printer containing text” defines the text to be searched into the 
printer name. 
Once the printers connected to the network have been discovered and identified with their IP-
address, they may be grouped in a logical way so that the user can access them quickly and easily.  
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The logical groups can be defined hierarchically allowing the navigation through nested device 
groups. The discovered printers may then be placed into each group. 
 
This structured database can be saved to disk and then retrieved. 
 
The organization process of the devices is performed through the following functions: 
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CCrreeaattee  aa  NNeeww  DDaattaabbaassee  
This is the starting procedure for organizing your printers. 
 
With the NetViewMaster Utility it is possible to create various printer databases and then 
organize the corresponding printers into folders and subfolders, reproducing the structure of 
single offices, departments, or the whole company. 
 

1. To create a new database, press the  button on the tool bar. The database name 
request appears: 

 

 
 

2. Enter a database name. 
 
Now you can structure and organize the database as follows: 
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AAddddiinngg  aa  NNeeww  FFoollddeerr  
1. Select Edit → Insert → Folder or press the  button on the NVM’s tool bar. The 

NetViewMaster Utility prompts for the folder name: 
 

 
 

2. Enter a name for the printer group you want to create and then click on the OK button. 

The NetViewMaster Utility is able to manage nested folders. The printer database may be 
structured as needed.  

OOrrggaanniizziinngg  tthhee  FFoollddeerrss  
Reorganize the Printers Already Present in the Database 
If you performed the automatic device discovery procedure described above, you will already 
have a list of printers connected to the network. In this case you have to reorganize these 
printers in the folder structure you created with the cut and paste procedure: 

Select the printer to put in the new folder and press the  button (or select Edit → Cut).  

Select the folder in which you want to put the printer and press the  button (or select  
Edit → Paste). 

The printer and the corresponding information now appear in the folder. 
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Inserting a Printer Manually 
To insert a printer manually at any time while organizing the database, as either the first 
printer or in addition to the existing printers in the database, proceed as follows: 
 

1. Select the folder in which you want to insert the printer and press the  button on the 
tools bar (or select Edit → Insert → Printer). 

 
2. The NetViewMaster Utility displays the printer data dialog box, in which the user must 

enter the printer’s parameters. It is necessary to specify the printer name (Identification 
parameter group), the IP Address, and Netmask (Net parameter group). 

 

  
 

For further details on how to fill in these masks, see “The Edit Menu”. 

As soon as the new printer data are confirmed, the NetViewMaster Utility tries to contact the 
printer in order to update its current status. 

If the printer is not found , the NetViewMaster Utility displays the printer in the database as “not ready”. 
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IInnsseerrttiinngg  aa  FFiirrmmwwaarree  FFiillee  iinnttoo  aa  FFoollddeerr  
A firmware file may be inserted into a folder to indicate the firmware version loaded on the 
printers contained in this folder. 
 

1. Press the  button on the tool bar (or select Edit → Insert → Firmware File), the following 
window appears:  

 

 
 

2. Press the “browse …” button, select the firmware file you want to insert into the folder, 
and press OK.  

3. The firmware file is shown in the selected folder with its identifier graphics F 
 

No firmware download is performed when inserting the firmware file into the folder. 

For information on how to download a new firmware version to the printers, see “Updating the 
Printer's Firmware Version”. 

More than one  firmware file can be added to each folder. 
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IInnsseerrttiinngg  aa  CCoonnffiigguurraattiioonn  FFiillee  iinnttoo  aa  FFoollddeerr  
 
A configuration file may be inserted into a folder to indicate the configuration set on the printers 
contained in this folder. 
 

1. Press the  button on the tool bar (or select Edit → Insert → Configuration File), the 
following window appears:  

 

 
 

2. Press the “browse …” button, select the Configuration File you want to insert into the 
folder, and press OK.  

 
3. The Configuration File is shown in the selected folder with its identifier graphics C  

 

No configuration updating is performed when inserting the configuration file into the folder. 

For information on how to update the configuration of the printers, see “Configuring the 
Printers in the Database”. 

More than one  configuration can  be added to each folder. 
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CChhaannggiinngg  tthhee  DDaattaabbaassee  SSttrruuccttuurree  
To further organize the folders, printers, firmware, and configuration files inserted in the 
database, the tool bar offers the following buttons: 
 

 Cut an item 

 
Copy an item 

 
Paste an item 

 
Edit an item 

 
Delete an item 

 

OOppttiimmiizziinngg  tthhee  DDaattaabbaassee  DDiissppllaayy  
The various folders, subfolders, and printer information may be expanded or hidden in order to 
optimize the information in the database window. For this purpose use the tool bar buttons: 
 

 Expand the display of the information Hide the information tree. 
 
You may also click on the  symbol, in the database window, to toggle between the expanded 
and reduced view of the information tree. 
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PPrriinntteerr  DDaattaabbaassee  MMaannaaggeemmeenntt  

CChheecckkiinngg  tthhee  PPrriinntteerr  SSttaattuuss  
Use NetViewMaster Utility program to check the status of the printers connected to the network 
. The Status Function in the NetViewMaster Utility menu offers two selections: 
 

 
 

Check Now NetViewMaster Utility performs a check on all the peripherals in the 
database and updates their statuses.  

Check List Printers 
W/E 

Selecting this function the NetViewMaster Utility performs a check on all 
printers connected to the network and will show only the printers that are 
“On-line” or “Warning” or in “Alarm” status as for the user selection. 

Check Periodically A flag for enabling or disabling the status polling. When the periodical check 
is selected the NetViewMaster Utility performs an automatic check every 
about 10 seconds. 

After the check the printers in the database are shown with the corresponding status 
indication: 

 
The printer in the database is ready and working normally. 

 
The printer in the database is ready and working, but a consumable, such as paper, is 
running out. The printer will need an operator’s intervention soon. 
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The printer in the database is in alarm or standby - no more jobs will be printed. An 
operator’s intervention is necessary.  

 
The printer in the database is not connected. The printer has been removed or the 
network connection is interrupted. An operator’s intervention is necessary 

CCoonnffiigguurriinngg  tthhee  PPrriinntteerrss  iinn  tthhee  DDaattaabbaassee  
The NetViewMaster Utility allows you to read a printer’s configuration, edit it, store it to disk 
and download the updated configuration to the printer. 
 
The best way to proceed is to read the existing configuration from the printer and to change it 
then as necessary. 
 

RReettrriieevviinngg  aa  CCoonnffiigguurraattiioonn  ffrroomm  aa  PPrriinntteerr  

This feature is only available for Compuprint  Serial Matrix Printers. 

1. Choose the printer configuration you want to upload. You have two methods: 
 

• Open the saved configuration file previously uploaded by pressing the  button on 
the tool bar or via the “Printer Configuration” into the “Printer Operation” 
menu. 

• Upload the configuration file with the current settings for the printer by pressing 
the   button on the tool bar or via the “Capture Printer Infos” into the menu 
“Printer Operation”. 

• The NetViewMaster Utility opens the Configuration Editor showing the 
configuration tree for editing. 
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For each parameter you can see the range of possible choices and the default setting by clicking 
on the parameter in the tree. (The following shows the Maximum Print Position parameter as an 
example). 
 

 



32 

EEddiittiinngg  aa  PPrriinntteerr  CCoonnffiigguurraattiioonn  
For each parameter in the printer configuration tree you can select the desired value.  
 

1. Click on the configuration parameter you want to set. The Printer Configuration Manager 
displays, in the lower part of the window, the default value and the currently set value of 
the parameter. 

 

Field Name

Default Value

Possible Choices

 
 

Click on the  symbol on the right side of the current value; the pull-down list of the 
possible values is shown for selection. 
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Field Name

Default Value

Possible Choices

 

Click on the value shown in the current value field. The pull-down menu closes and the 
new value is set. 

Set all the parameters in the same way. 

The values set are only stored in your PC’s RAM; no value has been set on the printers in the 
database. 

You may now send the new settings to the printer and/or save the configuration file with the 
new settings on the hard disk of your PC. 
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SSeennddiinngg  tthhee  CCoonnffiigguurraattiioonn  ttoo  tthhee  PPrriinntteerrss  
Once all the parameters in the configuration tree have been set the new configuration must be 
sent to the printers. 
 

1. In the Printer Configurator Menu, click on Configuration. You have two download 
possibilities: 

 

 
 Selecting: 

Send Modified 
Values: 

Only the updated values are sent to the selected printers. This 
procedure is faster. 

Send All Values: The whole set of configuration parameters is sent to the printers. 
This procedure assures that all configured printers have identical 
settings. 

Restore Default 
Configuration 

Restore the default Configuration into the working configuration file 
(not sent to printer). 

2. Selecting either Send Modified Values or Send All Values in the Printer Configurator Menu, 
the printer asks to confirm the selection: 
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 Selecting: 

Yes Downloading of the updated configuration begins (see next step 3). 
No The configuration is not downloaded and the NetViewMaster Utility displays 

again the Main Window. 
Cancel The configuration is not downloaded and the Printer Setup tree is displayed for 

further changes. 
 
3. Selecting Yes sends the updated configuration to the printer. 
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The program shows the progression bar during the download. At the end of the download 
procedure the printer is restarted with the new settings. 
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SSaavviinngg  tthhee  CCoonnffiigguurraattiioonn  FFiillee  ttoo  DDiisskk  
Once all the parameters in the configuration tree have been set, the configuration may be saved 
to disk. 
 
This allows you to have different configuration files with which to update your printers. 
 

1. After having edited the configuration tree, select File in the Printer Configurator Menu. 
 

 
 

2. Select Save. The NetViewMaster Utility prompts for a file name and folder. 
 
3. Enter a name for the configuration file and press OK. 

 
4. The configuration file is saved to disk. You may load it for editing and/or updating a 

printer with these settings. 
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UUppddaattiinngg  aa  PPrriinntteerr  oorr  aa  GGrroouupp  ooff  PPrriinntteerrss  UUssiinngg  aann  EExxiissttiinngg  
CCoonnffiigguurraattiioonn  FFiillee  
The configuration files on the hard disk of your computer may be used to update the printers in 
the network, for example, when new printers are installed and should be configured as the other 
printers in the same group or for reconfiguring all printers of a group. Proceed as follows: 
 

1. In the Main Window of the printer database position the cursor on the folder containing 
the printers to configure, then press the  button. The program shows the configuration 
file selection window: 

 

 
 

2. Enter the file name, or select the browse… button to select a configuration file. 
 

The NetViewMaster Utility shows the list of the devices that are compatible with the selected 
configuration file. 
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In this mask, you may select or deselect the printers that you want to configure by pressing on 
check field (  ) beside the printer or pressing on the first lower button: 
 

Unselect All / 
Select All 

Pressing this button, selects or unselects all printers in the list. 

Save Result Pressing this button, save in the selected .TXT file  the list of the devices 
compatible shown and  with all information. 
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Once the printers are selected, press the Send button. The Configuration File starts to download. 
 

 
 

• The first line on the screen indicates the printer that is being configured. 
• The second line indicates the parameter that is being updated. 
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Once the printers have been configured the NetViewMaster Utility shows the result of the 
download: 

 
• If the download was successful, the printer is checked with a green check sign: 

 

 
 

• If an error occurred during the download, the printer is checked with a red cross 
sign: 

 

 
 

When the configuration parameters have been sent to the printer, it is re-initialized to set the new 
printer configuration. 

After a group of printers has been updated, insert the configuration file used for the update into 
the folder containing the updated printers. See “Inserting a Configuration File into a Folder”.
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UUppddaattiinngg  tthhee  PPrriinntteerr’’ss  FFiirrmmwwaarree  VVeerrssiioonn  
 
The firmware downloading utility allows you to upgrade either the base board or the LAN card 
flash content. 
 
A single download operation can be done on a list of peripherals belonging to the same Folder in 
the Printer Database. 
 
Proceed as follows: 
 

1. In the NetViewMaster Utility Main Window select the folder containing the printers for 
which you want to update the firmware, and press the  button on the tool bar. 

 
2. The program displays the firmware file selection window: 

 

 
 

3. Enter the file name or select the browse… button to select the firmware file.
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The NetViewMaster Utility shows the list of printers that are compatible with the selected 
firmware file. 

 
 

In this mask, you may select or deselect the printers to which you want to download the 
firmware file by pressing the check field (  ) beside the printer or pressing on the first 
lower button: 
Unselect All / 
Select All 

Pressing this button, selects or unselects all printers in the list. 

Save Result Pressing this button, save in the selected .TXT file  the list of the devices 
compatible shown and  with all information. 
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Press the Send button to start downloading the Firmware Files to the selected printers. 

When the printers have been updated the NetViewMaster Utility shows the result of the 
download: 

 
• If the download was successful, the printer is checked with a green check sign: 

 

 
 

• If an error occurred during the download, the printer is checked with a red cross sign: 
 

 
 

After firmware downloading the printer is restarted with the new code release. 

 
After a group of printers has been updated, insert the configuration file used for the update into 
the folder containing the updated printers. See “Inserting a Firmware File into a Folder”.
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CCoonnffiigguurriinngg  aa  PPrriinntteerr  WWiitthh  tthhee  VViirrttuuaall  OOppeerraattoorr  PPaanneell  
 
For Compuprint Serial Matrix Printers, you can call up the corresponding virtual operator panel 
with all the keys, leds, and the display. 
 
You can then perform all printer operator panel functions on your computer in the same way as 
if you were in front of the printer. Click on the operator panel keys with your mouse. 
 
The following shows the virtual operator panel of the printer. 
 

 
 

To call up the virtual operator panel: 
 

1. Select the printer for which you want to see the virtual operator panel. 
 

a. Press the  button on the tool bar or via the “Operator Panel” into the menu 
“Printer Operation”.  

2. . The corresponding operator panel appears on the screen. 

For more details on the operator panel functions, please see the user manual of the 
corresponding printer. 
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UUppddaattiinngg  tthhee  PPrriinntteerr’’ss  LLiisstt  iinn  tthhee  DDaattaabbaassee  
When printers are connected to or removed from the network, you can update the structure by 
performing an update net scan. During the device discovery procedure the NetViewMaster 
Utility maps Copuprint  Serial Matrix Printers for complete management getting the proprietary 
MIB objects supported. Third-party vendor devices are mapped for basic status reporting. 
 
The update automatic device discovery is started by pressing the  button on the NVM’s tool 
bar. The following mask is displayed: 

 
 

The From and To IP-addresses define the start and stop addresses of the range in which the 
connected printers are checked. Mask defines the Netmask for the search procedure. The value 
set for Time out defines the time the program waits for a reply of a device connected to each IP-
address. After the time has passed, if no printer is detected, the program goes to the next IP 
address within the range. Setting of the Time-Out is useful when performing a device discovery 
procedure on large networks. 
The value set for Workgroup in textbox defines the workgroup name of printers to be searched. 
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The value set for “Search for Printer containing text” defines the text to be searched into the 
printer name. 
Once the printers connected to the network have been discovered and identified with their IP-
address, they may be grouped in a logical way so that the user can access them quickly and easily.  
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Discoveries are started only selecting the corresponding button on the NetViewMaster Utility tool 
bar. No means for automatically detecting new devices are provided. 

The printers found may be organized as described before in this manual. 
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AAppppeennddiixx  AA  --    
SSooffttwwaarree  IInnssttaallllaattiioonn  aanndd  DDooccuummeennttaattiioonn  

The NetViewMaster Utility software can be downloaded from our website at 
www.compuprint.com 
 

- NetViewMaster Utility installation files 
- Auto Installation for Microsoft environment 
- Java Run Time Environment version 6 
- Installation shell script for Unix and Linux environments 
- User Guide in PDF format 
- Software license agreement 

 
 
 
 
 
Trademarks:  
Compuprint  is the trademark of GDS . 
Java and all Java-based trademarks are trademarks of Sun Microsystems,Inc. in the United States, other countries, 
or both. 
Linux is a trademark of Linus Torvalds in the United States, other countries, or both 
Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United 
States, other countries, or both. 
UNIX is a registered trademark of The Open Group in the United States and other countries. 
Other company ,product,or service names may be trademarks or service marks of others. 




